Proxy server configuration for Windows

Forums Bug Reports Proxy server configuration for Windows

This topic contains 13 replies, has 11 voices, and was last updated by  pie 3 months, 3 weeks ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1243
    Oyauga
    Member

    Hello ! Forum, good morning from Europe / Spain:

    At home the installation was quick and easy with BootstrapStudio, behind a router-ADSL and like Windows 7-administrator.

    But at work, behind-sharing Router, Firewall, Proxy and Windows Policies applied, even though I’m local administrator of my machine, BootstrapStudio fails to start up.

    BootstrapStudio only presents a screen with its application border-framework and the background in white!

    I have looked in the application directory but can not find how to set BootstrapStudio beyond the default configuration. And I can’t either find any Registry-KEY configuration within RegEdit to solve this problem.

    Any suggestions ??

    Thanks a lot in advance. Best Regards.

    #1311
    Martin Angelov
    Bootstrap Studio Developer

    Hello,

    Sorry that you’ve run into this issue! As Bootstrap Studio needs to have internet connection the first time it starts, you will need to configure the proxy server manually. To do this, edit the shortcut to Bootstrap Studio on your desktop. Right click it, choose “Properties” in the menu, and add this switch at the end (outside the quotes for Bootstrap Studio.exe):

    --proxy-server="123.123.123.123:9999"

    Replace the ip address and port with that of your proxy server.

    If your proxy server also expects authentication, add this switch as well:

    --proxy-user-and-password=USERNAME:PASSWORD

    #1337
    Oyauga
    Member

    Just perfect!
    Many thanks Martin.
    It worked on the first try !.

    Best Regards.

    #2575
    kei.hiromasa
    Member

    Hi.

    I encountered the same problem, and the tip above doesn’t solved the probrem.

    Condition:
    Windows 7 32 bit
    behined a proxy server

    I added the proxy arguments to the shortcut, but it still displays white screen.

    I also tryed to boot the Studio from command line using the same proxy arguments, and I got the following log message
    (electron) ipc module is deprecated. Use require(“electron”).ipcMain instead.
    (electron) loadUrl is deprecated. Use loadURL instead.

    Any suggestions?

    Thanks.

    #2583
    Oyauga
    Member

    Hi Hiromasa,
    Can you view that:
    http://unix.stackexchange.com/questions/36627/how-to-telnet-via-proxy-authentication

    I revised that Post at at Stackoverflow.
    I installed telnet from Windows 7 / ( Control Panel – > Windows Installation Utilities -> Select Telnet).
    From Commnad-Line, I tested that all was right with proxy: i.e. proxy.YourDomain.com 3128

    I followed StackOverflow instruction
    And put parameters by Martin Angelov outside of the quotes of BootStrap Studio .exe sentences and with Administrative Privileges execution mode.

    Good luck!

    #4010
    Chrix
    Member

    Hi,

    On Windows 8.1, I’ve got a blank screen too.

    I launch Bootstrap Studio with this command line:

    "Bootstrap Studio.exe" --proxy-server="myproxy.com:8080"
    

    But I get the same error than hiromasa:

    (electron) ipc module is deprecated. Use require(“electron”).ipcMain
    instead. (electron) loadUrl is deprecated. Use loadURL instead.

    For information, I can telnet my proxy without problem.

    Any idea?

    Thanks.

    #5624
    bejmnito
    Member

    None of the above solutions worked for me. Can anyone help?

    #6363
    abenaa_o
    Member

    same as bejmnito!

    #7178
    montezi
    Member

    Didn’t work for me. Somebody help me

    #10735
    THA DREAD1
    Member

    I have Windows 10 Pro 64-bit and only get a black screen when I try to run Bootstrap Studio . Please help.

    #10764
    Oyauga
    Member

    Hi !,

    On Linux, I used:

    export http_proxy="http://User-Proxy-Name:PasswdOfThisUser@proxy.domain.domain:3128"
    export https_proxy="http://User-Proxy-Name:PasswdOfThisUser@proxy.domain.domain:3128"
    

    On Windows, I need to wrap declarations from the beginning of variable name with quotes:

    set "http_proxy=http://User-Proxy-Name:PasswdOfThisUser@proxy.domain.domain:3128"
    set "https_proxy=http://User-Proxy-Name:PasswdOfThisUser@proxy.domain.domain:3128"
    

    So, you can test: wget, or for instance, pip3.6 install neovim. Only then, when those utilities run perfect from command line, it was possible to me, running bootstrap-estudio installer with parameters.

    God luck !

    #11436
    sigmazen
    Member

    Hi
    Any ideas on how and where (file etc) to do this on macbook?
    Works at home, crashes behind proxy.
    Cheers

    #12174
    edivaldojr
    Member

    the program continues with a black screen, I can not get into work because here uses proxy

    <h2>enter image description here</h2>

    Server proxy server is set up and the program does not work at work

    enter image description here

    #12431
    pie
    Member

    Didn’t work for me, I have Windows 10 Pro 64-bit and only get a black screen.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.