Undesirable behavior on UI toggle switches

Forums Bug Reports Undesirable behavior on UI toggle switches

This topic contains 1 reply, has 2 voices, and was last updated by  Jo 4 days, 22 hours ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Printninja
    Member

    Not sure if this is actually a bug, or just an unusual choice on the part of the devs, but I notice that in the Options panel, on all the fields featuring a toggle switch, not only does clicking directly on the toggle change the setting, but so does clicking anywhere in the panel to the left of the toggle, up to and including the name of the item (see linked image.)

    Why is this a problem? Well, I accidentally clicked on that area and activated the “stretch” feature on a link without realizing it, and then spent a good amount of time trying to figure out why the link was acting so weird, and why I couldn’t select any of the other links to the right of it in my design. Finally, I noticed the stretch toggle had been selected, and I realized that clicking anywhere to the left of it activate/deactivates it. I think from a design perspective, a button/toggle/icon/dropdown/whatever should only work when you click directly on it, not in an arbitrary area around it.

    enter image description here

    Jo
    Member
    Valued

    Hmm I had a similar thing happen to me the other day. Never did figure out what it was that caused the link issues. I will go back in that project tomorrow and see if that’s what happened there too and let you know. That is definitely an issue for me if that’s the case, and I would imagine it’s a bug not a feature.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.